Inheritance Hierarchy
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public abstract class OsnapOverrule : Overrule
Public MustInherit Class OsnapOverrule
Inherits Overrule
public ref class OsnapOverrule abstract : public Overrule
[<AbstractClassAttribute>]
type OsnapOverrule =
class
inherit Overrule
end
The OsnapOverrule type exposes the
following members.
Constructors
|
Name |
Description |
|
OsnapOverrule
|
Initializes a new instance of the OsnapOverrule class
|
Top
Properties
Methods
|
Name |
Description |
|
Clone
|
(Inherited from RXObject.) |
|
CompareTo
|
(Inherited from RXObject.) |
|
CopyFrom
|
(Inherited from RXObject.) |
|
CreateObjRef
|
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
|
DeleteUnmanagedObject
|
(Inherited from RXObject.) |
|
Dispose
|
(Inherited from DisposableWrapper.) |
|
Dispose(Boolean)
|
(Inherited from DisposableWrapper.) |
|
Equals
|
(Inherited from DisposableWrapper.) |
|
Finalize
|
(Inherited from DisposableWrapper.) |
|
GetHashCode
|
(Inherited from DisposableWrapper.) |
|
GetLifetimeService
|
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
|
GetObjectSnapPoints(Entity,
ObjectSnapModes, IntPtr, Point3d, Point3d, Matrix3d,
Point3dCollection, IntegerCollection)
|
|
|
GetObjectSnapPoints(Entity,
ObjectSnapModes, IntPtr, Point3d, Point3d, Matrix3d,
Point3dCollection, IntegerCollection, Matrix3d)
|
|
|
GetRXClass
|
(Inherited from RXObject.) |
|
GetType
|
Gets the Type of the current instance.
(Inherited from Object.) |
|
InitializeLifetimeService
|
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
|
IsApplicable
|
(Inherited from Overrule.) |
|
IsContentSnappable
|
|
|
MemberwiseClone
|
Creates a shallow copy of the current Object.
(Inherited from Object.) |
|
MemberwiseClone(Boolean)
|
(Inherited from MarshalByRefObject.) |
|
QueryX
|
(Inherited from RXObject.) |
|
SetCustomFilter
|
(Overrides OverruleSetCustomFilter.) |
|
SetExtensionDictionaryEntryFilter
|
(Overrides OverruleSetExtensionDictionaryEntryFilter(String).) |
|
SetIdFilter
|
(Overrides OverruleSetIdFilter(ObjectId).) |
|
SetNoFilter
|
(Overrides OverruleSetNoFilter.) |
|
SetXDataFilter
|
(Overrides OverruleSetXDataFilter(String).) |
|
ToString
|
Returns a string that represents the current
object.
(Inherited from Object.) |
|
X
|
(Inherited from RXObject.) |
Top
See Also