OsnapOverruleGetObjectSnapPoints Method (Entity, ObjectSnapModes,
IntPtr, Point3d, Point3d, Matrix3d, Point3dCollection,
IntegerCollection, Matrix3d)
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public virtual void GetObjectSnapPoints(
Entity entity,
ObjectSnapModes snapMode,
IntPtr gsSelectionMark,
Point3d pickPoint,
Point3d lastPoint,
Matrix3d viewTransform,
Point3dCollection snapPoints,
IntegerCollection geometryIds,
Matrix3d insertionMat
)
Public Overridable Sub GetObjectSnapPoints (
entity As Entity,
snapMode As ObjectSnapModes,
gsSelectionMark As IntPtr,
pickPoint As Point3d,
lastPoint As Point3d,
viewTransform As Matrix3d,
snapPoints As Point3dCollection,
geometryIds As IntegerCollection,
insertionMat As Matrix3d
)
public:
virtual void GetObjectSnapPoints(
Entity^ entity,
ObjectSnapModes snapMode,
IntPtr gsSelectionMark,
Point3d pickPoint,
Point3d lastPoint,
Matrix3d viewTransform,
Point3dCollection^ snapPoints,
IntegerCollection^ geometryIds,
Matrix3d insertionMat
)
abstract GetObjectSnapPoints :
entity : Entity *
snapMode : ObjectSnapModes *
gsSelectionMark : IntPtr *
pickPoint : Point3d *
lastPoint : Point3d *
viewTransform : Matrix3d *
snapPoints : Point3dCollection *
geometryIds : IntegerCollection *
insertionMat : Matrix3d -> unit
override GetObjectSnapPoints :
entity : Entity *
snapMode : ObjectSnapModes *
gsSelectionMark : IntPtr *
pickPoint : Point3d *
lastPoint : Point3d *
viewTransform : Matrix3d *
snapPoints : Point3dCollection *
geometryIds : IntegerCollection *
insertionMat : Matrix3d -> unit
Parameters
- entity
- Type: Teigha.DatabaseServicesEntity
- snapMode
- Type: Teigha.DatabaseServicesObjectSnapModes
- gsSelectionMark
- Type: SystemIntPtr
- pickPoint
- Type: Teigha.GeometryPoint3d
- lastPoint
- Type: Teigha.GeometryPoint3d
- viewTransform
- Type: Teigha.GeometryMatrix3d
- snapPoints
- Type: Teigha.GeometryPoint3dCollection
- geometryIds
- Type: Teigha.GeometryIntegerCollection
- insertionMat
- Type: Teigha.GeometryMatrix3d
See Also