EnumeratorBase Class

Inheritance Hierarchy
Namespace:  Teigha.BoundaryRepresentation
Assembly:  TD_MgdBrep (in TD_MgdBrep.dll) Version: 0.0.0.0
Syntax
public abstract class EnumeratorBase : DisposableWrapper, 
        IEnumerator

The EnumeratorBase type exposes the following members.

Properties
Methods
  Name Description
Protected method DeleteUnmanagedObject (Overrides DisposableWrapperDeleteUnmanagedObject.)
Public method MoveNext
Public method Reset
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.BoundaryRepresentationEnumeratorBase
        Teigha.BoundaryRepresentationBrepComplexEnumerator
        Teigha.BoundaryRepresentationBrepEdgeEnumerator
        Teigha.BoundaryRepresentationBrepFaceEnumerator
        Teigha.BoundaryRepresentationBrepShellEnumerator
        Teigha.BoundaryRepresentationBrepVertexEnumerator
        Teigha.BoundaryRepresentationComplexShellEnumerator
        Teigha.BoundaryRepresentationEdgeLoopEnumerator
        Teigha.BoundaryRepresentationElement2dNodeEnumerator
        Teigha.BoundaryRepresentationFaceLoopEnumerator
        Teigha.BoundaryRepresentationLoopEdgeEnumerator
        Teigha.BoundaryRepresentationLoopVertexEnumerator
        Teigha.BoundaryRepresentationMesh2dElement2dEnumerator
        Teigha.BoundaryRepresentationShellFaceEnumerator
        Teigha.BoundaryRepresentationVertexEdgeEnumerator
        Teigha.BoundaryRepresentationVertexLoopEnumerator

©  Bricsys NV. All rights reserved.