OsnapPointRef Class |
The OsnapPointRef type exposes the following members.
Name | Description | |
---|---|---|
![]() |
OsnapPointRef |
Initializes a new instance of the OsnapPointRef class
|
![]() |
OsnapPointRef(IntPtr, Boolean) |
Initializes a new instance of the OsnapPointRef class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
IdPath | |
![]() |
IntIdPath | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
LastPointRef | |
![]() |
NearPointParam | |
![]() |
OsnapType | |
![]() |
Point | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
XrefHandles | |
![]() |
XrefIntHandles |
Name | Description | |
---|---|---|
![]() |
Clone | (Inherited from RXObject.) |
![]() |
CompareTo | (Inherited from RXObject.) |
![]() |
CopyFrom | (Inherited from RXObject.) |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
EvalPoint | (Overrides PointRefEvalPoint.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetEntities | (Overrides PointRefGetEntities(Boolean).) |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetRXClass | (Inherited from RXObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IntersectEntity | |
![]() |
IsGeomErased | (Overrides PointRefIsGeomErased.) |
![]() |
IsXrefObj | (Overrides PointRefIsXrefObj(ObjectIdCollection, ObjectIdCollection, Boolean).) |
![]() |
MainEntity | |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
QueryX | (Inherited from RXObject.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
UpdateDueToMirror | (Overrides PointRefUpdateDueToMirror(Boolean).) |
![]() |
UpdateSubentPath | (Overrides PointRefUpdateSubentPath(IdMapping).) |
![]() |
UpdateXrefSubentPath | (Overrides PointRefUpdateXrefSubentPath.) |
![]() |
X | (Inherited from RXObject.) |
© Bricsys NV. All rights reserved. |