HostApplicationServicesrecoverFile Method

Performs a recover operation on the specified file defined in a file buffer.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public Database recoverFile(
        StreamBuf fileBuff,
        AuditInfo auditInfo,
        string password
)

Parameters

fileBuff
Type: Teigha.RuntimeStreamBuf
[in] StreamBuf object from which to read the data.
auditInfo
Type: Teigha.DatabaseServicesAuditInfo
[in/out] AuditInfo object.
password
Type: SystemString
[in] Password for a file.

Return Value

Type: Database
Returns a handle to the database of the recovered file.
See Also

©  Bricsys NV. All rights reserved.