HostApplicationServices Class |
The HostApplicationServices type exposes the following members.
Name | Description | |
---|---|---|
![]() |
HostApplicationServices |
Initializes a new instance of the HostApplicationServices class
|
![]() |
HostApplicationServices(IntPtr, Boolean) |
Initializes a new instance of the HostApplicationServices class
|
Name | Description | |
---|---|---|
![]() |
AlternateFontName | |
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
CompanyName | |
![]() ![]() |
Current |
Represents the currently active host
application services object.
|
![]() |
FontMapFileName | |
![]() |
GRIPCOLOR | |
![]() |
GRIPHOT | |
![]() |
GRIPHOVER | |
![]() |
GRIPOBJLIMIT | |
![]() |
GRIPSIZE | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
LocalRootFolder | |
![]() |
MachineRegistryProductRootKey | |
![]() |
ModelerFlavor | |
![]() |
Product | |
![]() |
Program | |
![]() |
RegistryProductRootKey | |
![]() |
ReleaseMajorVersion | |
![]() |
ReleaseMinorVersion | |
![]() |
RoamableRootFolder | |
![]() |
TEXTFILL | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
UserRegistryProductRootKey | |
![]() |
VersionString | |
![]() ![]() |
WorkingDatabase |
Represents the currently active
database.
|
Name | Description | |
---|---|---|
![]() |
BitmapDevice |
Returns the gsBitmapDevice associated with
this HostApplicationServices object. Currently not
implemented.
|
![]() |
Clone | (Inherited from RXObject.) |
![]() |
CompareTo | (Inherited from RXObject.) |
![]() |
CopyFrom | (Inherited from RXObject.) |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Inherited from RXObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
FindFile |
Returns the fully qualified path to the
specified file.
|
![]() |
FindFileEx |
Returns the fully qualified path to the
specified file.
|
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetPassword(String, PasswordOptions) | Obsolete.
Host applications call this method internally
to display a password request dialog box. Currently not
implemented.
|
![]() |
GetPassword(String, PasswordOptions, String) |
Host applications call this method internally
to display a password request dialog box. Currently not
implemented.
|
![]() |
GetRemoteFile | |
![]() |
GetRXClass | (Inherited from RXObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
GetUrl | |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsUrl |
Determines whether the passed string is a
valid URL. Currently not implemented.
|
![]() |
LoadApplication |
Loads an application. Currently not
implemented.
|
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
NewProgressMeter |
Retrieves a progress bar that represents
visual progress of completion for some processes. Currently not
implemented.
|
![]() |
PutRemoteFile | |
![]() |
QueryX | (Inherited from RXObject.) |
![]() |
recoverFile |
Performs a recover operation on the specified
file defined in a file buffer.
|
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
![]() |
UserBreak |
Usually called by the database code to
determine whether the user has pressed a CTRL+C break. Currently
not implemented.
|
![]() |
X | (Inherited from RXObject.) |
© Bricsys NV. All rights reserved. |