RevolvedSurfaceCreateRevolvedSurface Method
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void CreateRevolvedSurface(
Entity revolveEntity,
Point3d axisPoint,
Vector3d axisDirection,
double revolveAngle,
double startAngle,
RevolveOptions revolveOptions
)
Public Sub CreateRevolvedSurface (
revolveEntity As Entity,
axisPoint As Point3d,
axisDirection As Vector3d,
revolveAngle As Double,
startAngle As Double,
revolveOptions As RevolveOptions
)
public:
void CreateRevolvedSurface(
Entity^ revolveEntity,
Point3d axisPoint,
Vector3d axisDirection,
double revolveAngle,
double startAngle,
RevolveOptions^ revolveOptions
)
member CreateRevolvedSurface :
revolveEntity : Entity *
axisPoint : Point3d *
axisDirection : Vector3d *
revolveAngle : float *
startAngle : float *
revolveOptions : RevolveOptions -> unit
Parameters
- revolveEntity
- Type: Teigha.DatabaseServicesEntity
- axisPoint
- Type: Teigha.GeometryPoint3d
- axisDirection
- Type: Teigha.GeometryVector3d
- revolveAngle
- Type: SystemDouble
- startAngle
- Type: SystemDouble
- revolveOptions
- Type: Teigha.DatabaseServicesRevolveOptions
See Also