Curve3dGetProjectedEntity Method (Plane, Vector3d,
Tolerance)
|
Retrieves the entity representing the curve's
projection onto the projection plane.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Entity3d GetProjectedEntity(
Plane projectionPlane,
Vector3d projectDirection,
Tolerance tolerance
)
Public Function GetProjectedEntity (
projectionPlane As Plane,
projectDirection As Vector3d,
tolerance As Tolerance
) As Entity3d
public:
Entity3d^ GetProjectedEntity(
Plane^ projectionPlane,
Vector3d projectDirection,
Tolerance tolerance
)
member GetProjectedEntity :
projectionPlane : Plane *
projectDirection : Vector3d *
tolerance : Tolerance -> Entity3d
Parameters
- projectionPlane
- Type: Teigha.GeometryPlane
[in] Plane on which the curve is to be projected.
- projectDirection
- Type: Teigha.GeometryVector3d
[in] Direction in which the curve is to be projected.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Entity3d
The entity that is the result of the projection.
See Also