Solid3dCreateRevolvedSolid Method (Entity, SubentityId, Point3d,
Vector3d, Double, Double, RevolveOptions)
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public virtual void CreateRevolvedSolid(
Entity profileEntity,
SubentityId faceSubEntityId,
Point3d axisPoint,
Vector3d axisDir,
double angleOfRevolution,
double startAngle,
RevolveOptions revolveOptions
)
Public Overridable Sub CreateRevolvedSolid (
profileEntity As Entity,
faceSubEntityId As SubentityId,
axisPoint As Point3d,
axisDir As Vector3d,
angleOfRevolution As Double,
startAngle As Double,
revolveOptions As RevolveOptions
)
public:
virtual void CreateRevolvedSolid(
Entity^ profileEntity,
SubentityId faceSubEntityId,
Point3d axisPoint,
Vector3d axisDir,
double angleOfRevolution,
double startAngle,
RevolveOptions^ revolveOptions
)
abstract CreateRevolvedSolid :
profileEntity : Entity *
faceSubEntityId : SubentityId *
axisPoint : Point3d *
axisDir : Vector3d *
angleOfRevolution : float *
startAngle : float *
revolveOptions : RevolveOptions -> unit
override CreateRevolvedSolid :
profileEntity : Entity *
faceSubEntityId : SubentityId *
axisPoint : Point3d *
axisDir : Vector3d *
angleOfRevolution : float *
startAngle : float *
revolveOptions : RevolveOptions -> unit
Parameters
- profileEntity
- Type: Teigha.DatabaseServicesEntity
- faceSubEntityId
- Type: Teigha.DatabaseServicesSubentityId
- axisPoint
- Type: Teigha.GeometryPoint3d
- axisDir
- Type: Teigha.GeometryVector3d
- angleOfRevolution
- Type: SystemDouble
- startAngle
- Type: SystemDouble
- revolveOptions
- Type: Teigha.DatabaseServicesRevolveOptions
See Also