Cylinder Constructor (Double, Point3d, Vector3d, Vector3d,
Interval, Double, Double)
|
Initializes a new instance of the
Cylinder class
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Cylinder(
double radius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
Interval height,
double startAngle,
double endAngle
)
Public Sub New (
radius As Double,
origin As Point3d,
axisOfSymmetry As Vector3d,
referenceAxis As Vector3d,
height As Interval,
startAngle As Double,
endAngle As Double
)
public:
Cylinder(
double radius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
Interval^ height,
double startAngle,
double endAngle
)
new :
radius : float *
origin : Point3d *
axisOfSymmetry : Vector3d *
referenceAxis : Vector3d *
height : Interval *
startAngle : float *
endAngle : float -> Cylinder
Parameters
- radius
- Type: SystemDouble
- origin
- Type: Teigha.GeometryPoint3d
- axisOfSymmetry
- Type: Teigha.GeometryVector3d
- referenceAxis
- Type: Teigha.GeometryVector3d
- height
- Type: Teigha.GeometryInterval
- startAngle
- Type: SystemDouble
- endAngle
- Type: SystemDouble
See Also