Cylinder Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class Cylinder : Surface

The Cylinder type exposes the following members.

Constructors
  Name Description
Public method Cylinder
Initializes a new instance of the Cylinder class
Public method Cylinder(Double, Point3d, Vector3d)
Initializes a new instance of the Cylinder class
Public method Cylinder(Double, Point3d, Vector3d, Vector3d, Interval, Double, Double)
Initializes a new instance of the Cylinder class
Top
Properties
  Name Description
Public property AxisOfSymmetry
Public property Height
Public property IsOuterNormal
Public property Origin
Public property Radius
Public property ReferenceAxis
Top
Methods
  Name Description
Public methodStatic member Create
Public method GetAngles
Public method GetHeightAt
Public method IntersectWith(LinearEntity3d)
Public method IntersectWith(LinearEntity3d, Tolerance)
Public method IsClosed
Public method IsClosed(Tolerance)
Public method Set(Double, Point3d, Vector3d)
Public method Set(Double, Point3d, Vector3d, Vector3d, Interval, Double, Double)
Public method SetAngles
Top
See Also

©  Bricsys NV. All rights reserved.