SurfaceTrimSurface Method
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public static void TrimSurface(
ObjectId blankSurfaceId,
ObjectIdCollection toolSurfaceIds,
ObjectIdCollection toolCurveIds,
Vector3dCollection projVectors,
Point3d pickPoint,
Vector3d viewVector,
bool bAutoExtend,
bool associativeEnabled
)
Public Shared Sub TrimSurface (
blankSurfaceId As ObjectId,
toolSurfaceIds As ObjectIdCollection,
toolCurveIds As ObjectIdCollection,
projVectors As Vector3dCollection,
pickPoint As Point3d,
viewVector As Vector3d,
bAutoExtend As Boolean,
associativeEnabled As Boolean
)
public:
static void TrimSurface(
ObjectId blankSurfaceId,
ObjectIdCollection^ toolSurfaceIds,
ObjectIdCollection^ toolCurveIds,
Vector3dCollection^ projVectors,
Point3d pickPoint,
Vector3d viewVector,
bool bAutoExtend,
bool associativeEnabled
)
static member TrimSurface :
blankSurfaceId : ObjectId *
toolSurfaceIds : ObjectIdCollection *
toolCurveIds : ObjectIdCollection *
projVectors : Vector3dCollection *
pickPoint : Point3d *
viewVector : Vector3d *
bAutoExtend : bool *
associativeEnabled : bool -> unit
Parameters
- blankSurfaceId
- Type: Teigha.DatabaseServicesObjectId
- toolSurfaceIds
- Type: Teigha.DatabaseServicesObjectIdCollection
- toolCurveIds
- Type: Teigha.DatabaseServicesObjectIdCollection
- projVectors
- Type: Teigha.GeometryVector3dCollection
- pickPoint
- Type: Teigha.GeometryPoint3d
- viewVector
- Type: Teigha.GeometryVector3d
- bAutoExtend
- Type: SystemBoolean
- associativeEnabled
- Type: SystemBoolean
See Also