RibbonPanelSourceCollection Class |
The RibbonPanelSourceCollection type exposes the following members.
Name | Description | |
---|---|---|
![]() |
RibbonPanelSourceCollection |
Initializes a new instance of the RibbonPanelSourceCollection class
|
Name | Description | |
---|---|---|
![]() |
Count |
Gets the number of elements actually contained
in the CollectionT.
(Inherited from CollectionRibbonPanelSource.) |
![]() |
Item |
Gets or sets the element at the specified
index.
(Inherited from CollectionRibbonPanelSource.) |
![]() |
Items |
Gets a IListT wrapper around the CollectionT.
(Inherited from CollectionRibbonPanelSource.) |
Name | Description | |
---|---|---|
![]() |
Add |
Adds an object to the end of the CollectionT.
(Inherited from CollectionRibbonPanelSource.) |
![]() |
BlockReentrancy |
Disallows reentrant attempts to change this
collection.
(Inherited from ObservableCollectionRibbonPanelSource.) |
![]() |
CheckReentrancy |
Checks for reentrant attempts to change this
collection.
(Inherited from ObservableCollectionRibbonPanelSource.) |
![]() |
Clear |
Removes all elements from the CollectionT.
(Inherited from CollectionRibbonPanelSource.) |
![]() |
ClearItems | (Inherited from RibbonObservableCollectionT.) |
![]() |
Clone | |
![]() |
Contains |
Determines whether an element is in the
CollectionT.
(Inherited from CollectionRibbonPanelSource.) |
![]() |
CopyFrom | |
![]() |
CopyTo |
Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target
array.
(Inherited from CollectionRibbonPanelSource.) |
![]() |
Equals | (Inherited from Object.) |
![]() |
Finalize |
Allows an object to try to free resources and
perform other cleanup operations before it is reclaimed by garbage
collection.
(Inherited from Object.) |
![]() |
Find | |
![]() |
GetEnumerator |
Returns an enumerator that iterates through
the CollectionT.
(Inherited from CollectionRibbonPanelSource.) |
![]() |
GetHashCode |
Serves as a hash function for a particular
type.
(Inherited from Object.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
IndexOf |
Searches for the specified object and returns
the zero-based index of the first occurrence within the entire
CollectionT.
(Inherited from CollectionRibbonPanelSource.) |
![]() |
Insert |
Inserts an element into the CollectionT at the specified index.
(Inherited from CollectionRibbonPanelSource.) |
![]() |
InsertItem |
Inserts an item into the collection at the
specified index.
(Inherited from ObservableCollectionRibbonPanelSource.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
Move |
Moves the item at the specified index to a new
location in the collection.
(Inherited from ObservableCollectionRibbonPanelSource.) |
![]() |
MoveItem |
Moves the item at the specified index to a new
location in the collection.
(Inherited from ObservableCollectionRibbonPanelSource.) |
![]() |
OnCollectionChanged |
Raises the CollectionChanged event with the provided
arguments.
(Inherited from ObservableCollectionRibbonPanelSource.) |
![]() |
OnPropertyChanged |
Raises the PropertyChanged event with the provided
arguments.
(Inherited from ObservableCollectionRibbonPanelSource.) |
![]() |
Remove |
Removes the first occurrence of a specific
object from the CollectionT.
(Inherited from CollectionRibbonPanelSource.) |
![]() |
RemoveAt |
Removes the element at the specified index of
the CollectionT.
(Inherited from CollectionRibbonPanelSource.) |
![]() |
RemoveItem |
Removes the item at the specified index of the
collection.
(Inherited from ObservableCollectionRibbonPanelSource.) |
![]() |
SetItem |
Replaces the element at the specified
index.
(Inherited from ObservableCollectionRibbonPanelSource.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
Name | Description | |
---|---|---|
![]() |
CollectionChanged |
Occurs when an item is added, removed,
changed, moved, or the entire list is refreshed.
(Inherited from ObservableCollectionRibbonPanelSource.) |
![]() |
PropertyChanged |
Occurs when a property value changes.
(Inherited from ObservableCollectionRibbonPanelSource.) |
© Bricsys NV. All rights reserved. |