LayerStateManager Class

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class LayerStateManager : RXObject

The LayerStateManager type exposes the following members.

Constructors
  Name Description
Public method LayerStateManager
Initializes a new instance of the LayerStateManager class
Top
Properties
  Name Description
Public property LastRestoredLayerState
Top
Methods
  Name Description
Public method CompareLayerStateToDb
Public method DeleteLayerState
Public method ExportLayerState
Public method GetLayerStateDescription
Public method GetLayerStateLayers
Public method GetLayerStateMask
Public method GetLayerStateNames
Public method HasLayerState
Public method ImportLayerState
Public method ImportLayerStateFromDb
Public method LayerStateHasViewportData
Public method LayerStatesDictionaryId
Public method RenameLayerState
Public method RestoreLayerState
Public method SaveLayerState
Public method SetLayerStateDescription
Public method SetLayerStateMask
Top
Events
Fields
See Also

©  Bricsys NV. All rights reserved.