Curve3dGetProjectedClosestPointTo Method (Point3d, Vector3d)
|
Retrieves the point on this curve closest to
the specified point when projected in the specified
direction.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public PointOnCurve3d GetProjectedClosestPointTo(
Point3d point,
Vector3d projectDirection
)
Public Function GetProjectedClosestPointTo (
point As Point3d,
projectDirection As Vector3d
) As PointOnCurve3d
public:
PointOnCurve3d^ GetProjectedClosestPointTo(
Point3d point,
Vector3d projectDirection
)
member GetProjectedClosestPointTo :
point : Point3d *
projectDirection : Vector3d -> PointOnCurve3d
Parameters
- point
- Type: Teigha.GeometryPoint3d
[in] Point to which the closest point on this curve is
calculated.
- projectDirection
- Type: Teigha.GeometryVector3d
[in] Projection direction.
Return Value
Type:
PointOnCurve3d
Closest point on this curve.
See Also