DwgFiler Class

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public abstract class DwgFiler : RXObject

The DwgFiler type exposes the following members.

Constructors
  Name Description
Protected method DwgFiler
Initializes a new instance of the DwgFiler class
Protected method DwgFiler(IntPtr, Boolean)
Initializes a new instance of the DwgFiler class
Top
Properties
Methods
  Name Description
Public method ReadAddress
Public method ReadBinaryChunk
Public method ReadBoolean
Public method ReadByte
Public method ReadBytes
Public method ReadDouble
Public method ReadHandle
Public method ReadHardOwnershipId
Public method ReadHardPointerId
Public method ReadInt16
Public method ReadInt32
Public method ReadInt64
Public method ReadPoint2d
Public method ReadPoint3d
Public method ReadScale3d
Public method ReadSoftOwnershipId
Public method ReadSoftPointerId
Public method ReadString
Public method ReadUInt16
Public method ReadUInt32
Public method ReadUInt64
Public method ReadVector2d
Public method ReadVector3d
Public method ResetFilerStatus
Public method Seek
Public method WriteAddress
Public method WriteBinaryChunk
Public method WriteBoolean
Public method WriteByte
Public method WriteBytes
Public method WriteDouble
Public method WriteHandle
Public method WriteHardOwnershipId
Public method WriteHardPointerId
Public method WriteInt16
Public method WriteInt32
Public method WriteInt64
Public method WritePoint2d
Public method WritePoint3d
Public method WriteScale3d
Public method WriteSoftOwnershipId
Public method WriteSoftPointerId
Public method WriteString
Public method WriteUInt16
Public method WriteUInt32
Public method WriteUInt64
Public method WriteVector2d
Public method WriteVector3d
Top
See Also

©  Bricsys NV. All rights reserved.