TableSelectSubRegion Method
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public virtual CellRange SelectSubRegion(
Point3d cornerPoint1,
Point3d cornerPoint2,
Vector3d selectionViewDirection,
Vector3d hitTestViewDirection,
SelectType selectionType,
bool includeCurrentSelection,
bool inPickFirst,
FullSubentityPath[] paths
)
Public Overridable Function SelectSubRegion (
cornerPoint1 As Point3d,
cornerPoint2 As Point3d,
selectionViewDirection As Vector3d,
hitTestViewDirection As Vector3d,
selectionType As SelectType,
includeCurrentSelection As Boolean,
inPickFirst As Boolean,
paths As FullSubentityPath()
) As CellRange
public:
virtual CellRange^ SelectSubRegion(
Point3d cornerPoint1,
Point3d cornerPoint2,
Vector3d selectionViewDirection,
Vector3d hitTestViewDirection,
SelectType selectionType,
bool includeCurrentSelection,
bool inPickFirst,
array<FullSubentityPath>^ paths
)
abstract SelectSubRegion :
cornerPoint1 : Point3d *
cornerPoint2 : Point3d *
selectionViewDirection : Vector3d *
hitTestViewDirection : Vector3d *
selectionType : SelectType *
includeCurrentSelection : bool *
inPickFirst : bool *
paths : FullSubentityPath[] -> CellRange
override SelectSubRegion :
cornerPoint1 : Point3d *
cornerPoint2 : Point3d *
selectionViewDirection : Vector3d *
hitTestViewDirection : Vector3d *
selectionType : SelectType *
includeCurrentSelection : bool *
inPickFirst : bool *
paths : FullSubentityPath[] -> CellRange
Parameters
- cornerPoint1
- Type: Teigha.GeometryPoint3d
- cornerPoint2
- Type: Teigha.GeometryPoint3d
- selectionViewDirection
- Type: Teigha.GeometryVector3d
- hitTestViewDirection
- Type: Teigha.GeometryVector3d
- selectionType
- Type: Teigha.DatabaseServicesSelectType
- includeCurrentSelection
- Type: SystemBoolean
- inPickFirst
- Type: SystemBoolean
- paths
- Type: Teigha.DatabaseServicesFullSubentityPath
Return Value
Type:
CellRange
See Also