RibbonItem Class |
The RibbonItem type exposes the following members.
Name | Description | |
---|---|---|
![]() |
RibbonItem |
Initializes a new instance of the RibbonItem class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
Id | |
![]() |
Image | |
![]() |
ImagePath | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
IsEnabled | |
![]() |
IsInitialized | |
![]() |
IsVisible | |
![]() |
LargeImage | |
![]() |
ShowImage | |
![]() |
ShowText | |
![]() |
Text | |
![]() |
ToolTip | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
![]() |
Width |
Name | Description | |
---|---|---|
![]() |
Clone | |
![]() |
CopyFrom | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
DeleteUnmanagedObject | (Overrides DisposableWrapperDeleteUnmanagedObject.) |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) |
Releases the unmanaged resources used by the
RibbonItem and optionally releases
the managed resources
(Overrides DisposableWrapperDispose(Boolean).) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
OnPropertyChanged | |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
Name | Description | |
---|---|---|
![]() |
Initialized | |
![]() |
PropertyChanged |
Name | Description | |
---|---|---|
![]() |
m_imageSource | |
![]() |
m_IsInitialized |
© Bricsys NV. All rights reserved. |