GraphNode Class |
The GraphNode type exposes the following members.
Name | Description | |
---|---|---|
![]() |
GraphNode |
Initializes a new instance of the GraphNode class
|
![]() |
GraphNode(IntPtr, Boolean) |
Initializes a new instance of the GraphNode class
|
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper.) |
![]() |
Data | |
![]() |
IsCycleNode | |
![]() |
IsDisposed | (Inherited from DisposableWrapper.) |
![]() |
NextCycleNode | |
![]() |
NumCycleIn | |
![]() |
NumCycleOut | |
![]() |
NumIn | |
![]() |
NumOut | |
![]() |
Owner | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper.) |
Name | Description | |
---|---|---|
![]() |
AddRefTo | |
![]() |
Clear | |
![]() |
CreateObjRef |
Creates an object that contains all the
relevant information required to generate a proxy used to
communicate with a remote object.
(Inherited from MarshalByRefObject.) |
![]() |
CycleIn | |
![]() |
CycleOut | |
![]() |
DeleteUnmanagedObject | (Overrides DisposableWrapperDeleteUnmanagedObject.) |
![]() |
DisconnectAll | |
![]() |
Dispose | (Inherited from DisposableWrapper.) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper.) |
![]() |
Equals | (Inherited from DisposableWrapper.) |
![]() |
Finalize | (Inherited from DisposableWrapper.) |
![]() |
GetHashCode | (Inherited from DisposableWrapper.) |
![]() |
GetLifetimeService |
Retrieves the current lifetime service object
that controls the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
In | |
![]() |
InitializeLifetimeService |
Obtains a lifetime service object to control
the lifetime policy for this instance.
(Inherited from MarshalByRefObject.) |
![]() |
IsMarkedAs | |
![]() |
MarkAs | |
![]() |
MarkTree | |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
MemberwiseClone(Boolean) |
Creates a shallow copy of the current MarshalByRefObject object.
(Inherited from MarshalByRefObject.) |
![]() |
Out | |
![]() |
RemoveRefTo | |
![]() |
SetEdgeGrowthRate | |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
© Bricsys NV. All rights reserved. |