AssocActionGetActionsDependentOnObject Method (DBObject, Boolean, Boolean, ObjectIdCollection)

Retrieves the actions depending on the specified database object.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public static void GetActionsDependentOnObject(
        DBObject dbObj,
        bool readDependenciesWanted,
        bool writeDependenciesWanted,
        ObjectIdCollection actionIds
)

Parameters

dbObj
Type: Teigha.DatabaseServicesDBObject
[in] Database object for which to retrieve dependent actions. Must be opened at least for read operations.
readDependenciesWanted
Type: SystemBoolean
[in] Flag that specifies whether actions that depend on the object should be retrieved.
writeDependenciesWanted
Type: SystemBoolean
[in] Flag that specifies whether actions that modify the object should be retrieved.
actionIds
Type: Teigha.DatabaseServicesObjectIdCollection
[in] Identifiers of the dependent actions.
See Also

©  Bricsys NV. All rights reserved.