EllipticalConeSet Method (Double, Double, Point3d, Double, Double,
Vector3d, Vector3d, Interval, Double, Double)
|
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void Set(
double cosineAngle,
double sineAngle,
Point3d baseCenter,
double minorRadius,
double majorRadius,
Vector3d axisOfSymmetry,
Vector3d refAxis,
Interval height,
double startAngle,
double endAngle
)
Public Sub Set (
cosineAngle As Double,
sineAngle As Double,
baseCenter As Point3d,
minorRadius As Double,
majorRadius As Double,
axisOfSymmetry As Vector3d,
refAxis As Vector3d,
height As Interval,
startAngle As Double,
endAngle As Double
)
public:
void Set(
double cosineAngle,
double sineAngle,
Point3d baseCenter,
double minorRadius,
double majorRadius,
Vector3d axisOfSymmetry,
Vector3d refAxis,
Interval^ height,
double startAngle,
double endAngle
)
member Set :
cosineAngle : float *
sineAngle : float *
baseCenter : Point3d *
minorRadius : float *
majorRadius : float *
axisOfSymmetry : Vector3d *
refAxis : Vector3d *
height : Interval *
startAngle : float *
endAngle : float -> unit
Parameters
- cosineAngle
- Type: SystemDouble
- sineAngle
- Type: SystemDouble
- baseCenter
- Type: Teigha.GeometryPoint3d
- minorRadius
- Type: SystemDouble
- majorRadius
- Type: SystemDouble
- axisOfSymmetry
- Type: Teigha.GeometryVector3d
- refAxis
- Type: Teigha.GeometryVector3d
- height
- Type: Teigha.GeometryInterval
- startAngle
- Type: SystemDouble
- endAngle
- Type: SystemDouble
See Also