EllipticalCone Class

Inheritance Hierarchy
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public sealed class EllipticalCone : Surface

The EllipticalCone type exposes the following members.

Constructors
  Name Description
Public method EllipticalCone
Initializes a new instance of the EllipticalCone class
Public method EllipticalCone(Double, Double, Point3d, Double, Double, Vector3d)
Initializes a new instance of the EllipticalCone class
Public method EllipticalCone(Double, Double, Point3d, Double, Double, Vector3d, Vector3d, Interval, Double, Double)
Initializes a new instance of the EllipticalCone class
Top
Properties
Methods
  Name Description
Public methodStatic member Create
Public method GetAngles
Public method GetHalfAngles
Public method GetHeightAt
Public method IsClosed
Public method IsClosed(Tolerance)
Public method Set(Double, Double, Point3d, Double, Double, Vector3d)
Public method Set(Double, Double, Point3d, Double, Double, Vector3d, Vector3d, Interval, Double, Double)
Public method SetAngles
Top
See Also

©  Bricsys NV. All rights reserved.