QuadReactor Class

Inheritance Hierarchy
Namespace:  Bricscad.Quad
Assembly:  BrxMgd (in BrxMgd.dll) Version: 21.0.0.15598
Syntax
public abstract class QuadReactor : DisposableWrapper

The QuadReactor type exposes the following members.

Constructors
  Name Description
Public method QuadReactor
Initializes a new instance of the QuadReactor class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method appendQuadItems(QuadItems)
This function is called when the no-selection Quad is to be shown. Add selection-independent items in this function.
Public method appendQuadItems(QuadSelection, QuadItems)
Implement appendQuadItems to append QuadItems to the Quad. This function will be called when the Quad is about to be shown. Only those QuadItems that have been registered will be successfully appended. Several reactors may be registered, but only those which are active (as per settings) will append their items to the Quad. * This function is called when a Quad is to be shown for a selection. AcEdQuadSelection can be queried further for hovered and pickfirst selection data, to make intelligent decisions of relevant QuadItems to be added to the Quad.
Protected method DeleteUnmanagedObject (Overrides DisposableWrapperDeleteUnmanagedObject.)
Public method displayName
The display name will be shown to users in the UI for identifying/enabling/disabling/ prioritising your reactor.
Protected method GetImpObj
Public method GUID
The GUID has to be a globally unique identifier (use VS201x->Tools->CreateGUID, "guidgen.exe") and will be used to internally identify the reactor across sessions, releases and different third party applications, so it should always be the same for this reactor. Therefore, once a reactor is published by a developer, its GUID should NEVER be changed. Note : any string format from "CreateGUID" / "guidgen.exe" is accepted, suggested format is like "C2160591-FC06-4A74-A9B8-2E28635279BA" (not brackets)
Public method registerQuadItems
This function is called whenever BricsCAD needs to know ALL the commands supported by your reactor during, but not limited to loading of your module, adding your reactor to the AcEdQuadReactorManager, displaying the CUI dialog. Your implementation of this interface is expected to call AcEdQuadItemRegistry::append() for each QuadItem your reactor supports / requires. If a QuadItem has not been registered, AcEdQuadItems::append will not append that QuadItem to the Quad when its shown.
Public methodStatic member registerQuadReactor
Registers a Quad reactor. Reactor is added to the internal list, but caller owns the memory. Function returns false if another reactor has same GUID (the reactor will not get added in that case).
Public methodStatic member unregisterQuadReactor
Unregisters a Quad reactor. Reactor is removed from the internal list, caller still owns the memory. Function returns false if reactor was not present in the list.
Top
See Also

©  Bricsys NV. All rights reserved.