MPolygonIsPointInsideMPolygon
Method
|
Projects the specified point to the polygon
plane, then if the point is on a boundary, returns the index or
indices (because boundaries can touch), otherwise it finds the
innermost loop or loops containing the point and returns the
corresponding loop index or indices.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual IntegerCollection IsPointInsideMPolygon(
Point3d worldPoint,
double tolerance
)
Public Overridable Function IsPointInsideMPolygon (
worldPoint As Point3d,
tolerance As Double
) As IntegerCollection
public:
virtual IntegerCollection^ IsPointInsideMPolygon(
Point3d worldPoint,
double tolerance
)
abstract IsPointInsideMPolygon :
worldPoint : Point3d *
tolerance : float -> IntegerCollection
override IsPointInsideMPolygon :
worldPoint : Point3d *
tolerance : float -> IntegerCollection
Parameters
- worldPoint Point3d
- [in] Point in WCS.
- tolerance Double
- [in] Measurement accuracy tolerance.
Return Value
IntegerCollection
Index/indices of the boundary (boundaries) on which the projected
point lies, or index/indices of the innermost loop containing the
point.
See Also