TableSetGridLineStyle
Method
|
Sets the grid linestyle of a cell, row or
column. Use a valid row index and pass the column index '-1' to set
the row grid line style. Use a valid column index and pass the row
index '-1' to set the column grid line style.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetGridLineStyle(
int row,
int column,
GridLineType gridLineType,
GridLineStyle lineStyle
)
Public Overridable Sub SetGridLineStyle (
row As Integer,
column As Integer,
gridLineType As GridLineType,
lineStyle As GridLineStyle
)
public:
virtual void SetGridLineStyle(
int row,
int column,
GridLineType gridLineType,
GridLineStyle lineStyle
)
abstract SetGridLineStyle :
row : int *
column : int *
gridLineType : GridLineType *
lineStyle : GridLineStyle -> unit
override SetGridLineStyle :
row : int *
column : int *
gridLineType : GridLineType *
lineStyle : GridLineStyle -> unit
Parameters
- row Int32
- [in] Row index.
- column Int32
- [in] Column index.
- gridLineType GridLineType
- [in] Grid linetype.
- lineStyle GridLineStyle
- [in] Grid line stype.
Remarks
The gridlineType
parameter must have one of the following values:
NameValueDescriptionHorizontalTop 0x01 Top or
bottom horizontal table's grid line, depending on the flow
direction of the table rows (down or up). HorizontalInside 0x02 All
horizontal grid lines, excluding the bottom and top lines.
HorizontalBottom 0x04 Bottom or top horizontal table's grid line,
depending on the flow direction of the table rows (down or up).
VerticalLeft 0x08 The grid line at the left of the table.
VerticalInside 0x10 All vertical grid lines, excluding the left and
right lines. VerticalRight 0x20 The grid line at the right of the
table.
See Also