TableGridLineWeight(Int32,
Int32, CellEdgeMasks) Method
|
Returns the grid lineweight for the specified
cell and edge in this table entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual LineWeight GridLineWeight(
int row,
int col,
CellEdgeMasks edge
)
Public Overridable Function GridLineWeight (
row As Integer,
col As Integer,
edge As CellEdgeMasks
) As LineWeight
public:
virtual LineWeight GridLineWeight(
int row,
int col,
CellEdgeMasks edge
)
abstract GridLineWeight :
row : int *
col : int *
edge : CellEdgeMasks -> LineWeight
override GridLineWeight :
row : int *
col : int *
edge : CellEdgeMasks -> LineWeight
Parameters
- row Int32
- [in] Row index.
- col Int32
- [in] Column index.
- edge CellEdgeMasks
- [in] Edge type.
Return Value
LineWeight
Grid color value.
Remarks
The edge parameter
must have one of the following values:
NameValueDescriptionTopMask 1 Top-edge index
of the table cell. RightMask 2 Right-edge index of the table cell.
BottomMask 4 Bottom-edge index of the table cell. LeftMask 8
Left-edge index of the table cell.
See Also