LoftedSurfaceCreateLoftedSurface Method

Creates a lofted surface from the specified curves according to the specified lofting options.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void CreateLoftedSurface(
        Entity[] crossSections,
        Entity[] guideCurves,
        Entity pathCurve,
        LoftOptions loftOptions
)

Parameters

crossSections  Entity
[in] Array of curve entities to use as cross sections for the lofting operation.
guideCurves  Entity
[in] Array of guide curves.
pathCurve  Entity
[in] Path curve.
loftOptions  LoftOptions
[in] A set of loft options.
Remarks
All curve entities must be either open or closed. When all curves are closed, this method accepts a point entity as the first and (or) last array element. This means that each curve in the guideCurves array must intersect each of the cross-section curves, so the guide curves form a net-like structure with the cross-section curves. The cross-section and guide curves are allocated on the created surface. The pathCurve should be NULL if any guide curves are specified and vice versa (empty array of guide curves if pathCurve is used). If pathCurve is not NULL, the created surface follows its shape (as close as possible). The path curve does not need to intersect the cross-section curves and does not even need to be near the cross sections.
See Also

©  Bricsys NV. All rights reserved.