LoftOptions Class

This class stores loft options used for creating lofted surfaces and lofted solids. Loft options are used to control the shape of the resulting surface or solid object.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesLoftOptions

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class LoftOptions : DisposableWrapper, 
        ICloneable

The LoftOptions type exposes the following members.

Constructors
  Name Description
Public method LoftOptions Default constructor for the LoftOptions class.
Public method LoftOptions(LoftOptions) Copy constructor for the LoftOptions class.
Protected method LoftOptions(IntPtr, Boolean) Initializes a new instance of the LoftOptions class
Top
Properties
  Name Description
Public property AlignDirection Property that indicates whether the direction alignment flag is set. The direction alignment flag is used to orient each of the cross-sections so that the normal vector of each cross section points towards the next cross section. If the cross sections are not all oriented in the same direction, this flag should be used to avoid creating a twisted or self-intersecting surface.
Public property ArcLengthParam Property that indicates whether arc length parameterization is applied.
Public property Closed Property that indicates whether the closed flag is set. If the closed flag is set to true, the created surface starts and ends at the first cross section (i.e., the surface is closed). If all of the cross sections are closed, the resulting surface is a torus-like shape. If the closed flag is set to false, the surface is opened or capped with a planar surface at the first and last cross sections. If the flag is set, there must be at least three cross sections.
Public property DraftEnd Property that represents the end draft angle in radians. This value relates to the surface take-off direction at the last cross-section. The default value is 0; no draft angle is applied and the optimum angle is calculated at the last cross-section.
Public property DraftEndMag Property that represents the end draft magnitude. This value relates to the magnitude of the surface tangent vector at the last cross-section. The default value is 0; the optimum magnitude is calculated at the last cross-section.
Public property DraftStart Property that represents the start draft angle in radians. This value relates to the surface take-off direction at the first cross-section. The default value is 0; no draft angle is applied and the optimum angle is calculated at the first cross-section.
Public property DraftStartMag Property that represents the start draft magnitude. This value relates to the magnitude of the surface tangent vector at the first cross-section. The default value is 0; the optimum magnitude is calculated at the last cross-section.
Public property NormalOption Property that represents the plane normal flag. The default value of the flag is NoNormal.
Public property NoTwist Property that indicates whether the noTwist flag is set. This flag can be used to minimize the amount of twist in the surface when the cross-sections are all closed. The default value is true; the start point of each closed cross-section is aligned with the other cross-sections to minimize the twist.
Public property Ruled Property that indicates whether the ruled flag is set. If the flag is set to true, a ruled surface is created between each pair of cross sections, which leads to a coarser surface. If the flag is set to false, a single smooth surface is created. The default value is false.
Public property Simplify Property that indicates whether the simplify flag is set. If the simplify flag is set to true, simple surface types (such as a plane, cylinder, cone, sphere and torus) are created whenever all of the cross sections lie on such a surface. If the simplify flag is set to false, a general surface type is created. The default value is true.
Public property VirtualGuide Property that indicates whether the virtual guide option is used for creating loft surfaces or solids.
Top
Methods
  Name Description
Public method CheckCrossSectionCurves Checks whether cross section curves are valid for the lofting operation.
Public method CheckGuideCurves Checks whether guide curves are valid for the lofting operation.
Public method CheckLoftCurves Checks whether cross section curves and path curves are valid for the lofting operation.
Public method CheckPathCurve Checks whether a path curve is valid for the lofting operation.
Public method Clone Clones this object.
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Top
See Also

©  Bricsys NV. All rights reserved.