Curve3dIsOn(Point3d, Double,
Tolerance) Method
|
Checks whether a specified point lies on this
curve.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsOn(
Point3d point,
out double value,
Tolerance tolerance
)
Public Function IsOn (
point As Point3d,
<OutAttribute> ByRef value As Double,
tolerance As Tolerance
) As Boolean
public:
bool IsOn(
Point3d point,
[OutAttribute] double% value,
Tolerance tolerance
)
member IsOn :
point : Point3d *
value : float byref *
tolerance : Tolerance -> bool
Parameters
- point Point3d
- [in] Point to be checked.
- value Double
- [out] Receives the parameter value that corresponds to the
point on the curve.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Boolean
true if the specified point lies on this
curve,
false otherwise.
See Also