Solid3dCreateLoftedSolid Method
|
Creates a lofted solid from the specified
curves.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void CreateLoftedSolid(
Entity[] crossSectionCurves,
Entity[] guideCurves,
Entity pathCurve,
LoftOptions loftOptions
)
Public Overridable Sub CreateLoftedSolid (
crossSectionCurves As Entity(),
guideCurves As Entity(),
pathCurve As Entity,
loftOptions As LoftOptions
)
public:
virtual void CreateLoftedSolid(
array<Entity^>^ crossSectionCurves,
array<Entity^>^ guideCurves,
Entity^ pathCurve,
LoftOptions^ loftOptions
)
abstract CreateLoftedSolid :
crossSectionCurves : Entity[] *
guideCurves : Entity[] *
pathCurve : Entity *
loftOptions : LoftOptions -> unit
override CreateLoftedSolid :
crossSectionCurves : Entity[] *
guideCurves : Entity[] *
pathCurve : Entity *
loftOptions : LoftOptions -> unit
Parameters
- crossSectionCurves Entity
- [in] Array of curve entities to use as cross sections for the
lofting operation.
- guideCurves Entity
- [in] Array of guide curves.
- pathCurve Entity
- [in] Path curve.
- loftOptions LoftOptions
- [in] Options for lofting.
Remarks
This method is
implemented only for the Spatial modeler.
See Also