Curve2dGetParameterOf(Point2d,
Tolerance) Method
|
Retrieves the parameter value of a point
within a specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public double GetParameterOf(
Point2d point,
Tolerance tolerance
)
Public Function GetParameterOf (
point As Point2d,
tolerance As Tolerance
) As Double
public:
double GetParameterOf(
Point2d point,
Tolerance tolerance
)
member GetParameterOf :
point : Point2d *
tolerance : Tolerance -> float
Parameters
- point Point2d
- [in] Point on the curve.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Double
Parameter value as the
double type.
Remarks
If the point is
not on the curve, the results are unpredictable. If you are not
sure the point is on the curve, use the isOn () method
instead.
See Also