AssocDependencyGetDependenciesOnObject
Method
|
Retrieves the dependencies on the specified
database object.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public static ObjectIdCollection GetDependenciesOnObject(
DBObject dbObj,
bool readDependenciesWanted,
bool writeDependenciesWanted
)
Public Shared Function GetDependenciesOnObject (
dbObj As DBObject,
readDependenciesWanted As Boolean,
writeDependenciesWanted As Boolean
) As ObjectIdCollection
public:
static ObjectIdCollection^ GetDependenciesOnObject(
DBObject^ dbObj,
bool readDependenciesWanted,
bool writeDependenciesWanted
)
static member GetDependenciesOnObject :
dbObj : DBObject *
readDependenciesWanted : bool *
writeDependenciesWanted : bool -> ObjectIdCollection
Parameters
- dbObj DBObject
- [in] Identifier of the object for which to retrieve
dependencies.
- readDependenciesWanted Boolean
- [in] Flag that specifies whether objects that have the
read-dependency on the specified object should be retrieved.
- writeDependenciesWanted Boolean
- [in] Flag that specifies whether objects that have the
write-dependency on the specified object should be retrieved.
Return Value
ObjectIdCollection
A collection of identifiers of objects that have read and/or write
dependencies on the the specified object.
See Also