NurbCurve3d(Point3dCollection,
Vector3dCollection, Tolerance, Boolean)
Constructor
|
Constructor for the NurbCurve3d class.
Constructs a 3D polynomial curve interpolating a given array of 3D
points according to the specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public NurbCurve3d(
Point3dCollection fitPoints,
Vector3dCollection fitTangents,
Tolerance fitTolerance,
bool periodic
)
Public Sub New (
fitPoints As Point3dCollection,
fitTangents As Vector3dCollection,
fitTolerance As Tolerance,
periodic As Boolean
)
public:
NurbCurve3d(
Point3dCollection^ fitPoints,
Vector3dCollection^ fitTangents,
Tolerance fitTolerance,
bool periodic
)
new :
fitPoints : Point3dCollection *
fitTangents : Vector3dCollection *
fitTolerance : Tolerance *
periodic : bool -> NurbCurve3d
Parameters
- fitPoints Point3dCollection
- [in] Array of 3D points through which to fit the curve.
- fitTangents Vector3dCollection
- [in] Vectors interpolating the curve's derivatives at the fit
points.
- fitTolerance Tolerance
- [in] Fit tolerance.
- periodic Boolean
- [in] Flag that specifies whether to make the curve periodic (a
closed curve).
Remarks
If isPeriodic =
true, the first and the last fitPoints must be identical. The same
must be true for fitTangents.
See Also