Vector3dCollection Class

This class represents a collection of 3d vectors. For more information, see Working with Basic Geometry Types.
Inheritance Hierarchy
SystemObject
  Teigha.GeometryVector3dCollection

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class Vector3dCollection : IList

The Vector3dCollection type exposes the following members.

Constructors
  Name Description
Public method Vector3dCollection Default constructor for the Vector3dCollection class. Creates an empty collection of 3d vectors.
Public method Vector3dCollection(Int32) Constructor for the Vector3dCollection class. Creates an empty collection of 3d vectors with start capacity.
Public method Vector3dCollection(Vector3d) Constructor for the Vector3dCollection class. Creates a collection of 3d vectors from the passed array.
Top
Properties
  Name Description
Public property Capacity Represents the number of elements that this collection can contain.
Public property Count Represents the number of elements that this collection currently stores.
Protected property IList_Item  
Public property IsFixedSize Property that indicates whether this collection has a fixed size.
Public property IsReadOnly Property that indicates whether this collection is read-only.
Public property IsSynchronized Property that indicates whether access to this collection is thread-safe.
Public property Item Property that represents an item from the collection at the specified index.
Public property SyncRoot Property that represents an object that can be used to synchronize access to this collection.
Top
Methods
  Name Description
Public method Add Adds a vector to the collection.
Public method AddRange Adds a range of vectors to the end of this collection. This method grows the collection capacity if necessary.
Public method Clear Clears this collection of 3d vectors.
Public method Contains Checks whether this collection contains a vector that matches the specified vector.
Public method CopyTo Copies this vector collection to specified array at the specified index.
Public method GetEnumerator Returns enumerator for this vector collection.
Protected method ICollection_CopyTo  
Protected method IEnumerable_GetEnumerator  
Protected method IList_Add  
Protected method IList_Contains  
Protected method IList_IndexOf  
Protected method IList_Insert  
Protected method IList_Remove  
Public method IndexOf Returns index of the vector in collection that matches the specified vector.
Public method Insert Inserts the specified vector to the collection at the provided index.
Public method Remove Removes a vector in the collection that matches the specified vector.
Public method RemoveAt Removes a vector from the collection at the specified index.
Public method ToArray Returns this collection as an array of 3d vectors.
Public method TrimToSize Sets the capacity to the actual number of elements in this integer collection.
Top
Fields
  Name Description
Public fieldStatic member DefaultSize Size of the default vector collection.
Top
See Also

©  Bricsys NV. All rights reserved.