EllipticalArc3dClosestPointToPlane(PlanarEntity,
Tolerance) Method
|
Calculates the point on the elliptical arc
that is closest to the specified plane and the point on the
specified plane that is closest to the elliptical arc.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] ClosestPointToPlane(
PlanarEntity plane,
Tolerance tolerance
)
Public Function ClosestPointToPlane (
plane As PlanarEntity,
tolerance As Tolerance
) As Point3d()
public:
array<Point3d>^ ClosestPointToPlane(
PlanarEntity^ plane,
Tolerance tolerance
)
member ClosestPointToPlane :
plane : PlanarEntity *
tolerance : Tolerance -> Point3d[]
Parameters
- plane PlanarEntity
- [in] A plane to which a closest point is calculated.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Point3d
Array with two points. The first point is the closest point on the
specified plane, and the second point is the closest point on this
arc.
See Also