CoordinateSystem3d Constructor
|
Constructor for the CoordinateSystem3d
structure.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public CoordinateSystem3d(
Point3d o,
Vector3d x,
Vector3d y
)
Public Sub New (
o As Point3d,
x As Vector3d,
y As Vector3d
)
public:
CoordinateSystem3d(
Point3d o,
Vector3d x,
Vector3d y
)
new :
o : Point3d *
x : Vector3d *
y : Vector3d -> CoordinateSystem3d
Parameters
- o Point3d
- [in] Coordinate system origin.
- x Vector3d
- [in] Defines the positive direction of the x-axis of this
system.
- y Vector3d
- [in] Defines the positive direction of the y-axis of this
system.
Remarks
The z-axis is
calculated as x.CrossProduct(y).
See Also