NurbSurfaceModifyPositionAndTangent
Method
|
Adjusts the location and tangent of a point on
the surface with the specified parameter ([u, v]). The local
control points are adjusted accordingly. If the pointer uDeriv and
vDeriv are NULL, only the location of the point is adjusted.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void ModifyPositionAndTangent(
double dU,
double dV,
Point3d point,
Vector3d uDeriv,
Vector3d vDeriv
)
Public Sub ModifyPositionAndTangent (
dU As Double,
dV As Double,
point As Point3d,
uDeriv As Vector3d,
vDeriv As Vector3d
)
public:
void ModifyPositionAndTangent(
double dU,
double dV,
Point3d point,
Vector3d uDeriv,
Vector3d vDeriv
)
member ModifyPositionAndTangent :
dU : float *
dV : float *
point : Point3d *
uDeriv : Vector3d *
vDeriv : Vector3d -> unit
Parameters
- dU Double
- [in] U parameter.
- dV Double
- [in] V parameter.
- point Point3d
- [in] A new location of the point on the surface.
- uDeriv Vector3d
- [in] The tangent vector in the u-direction.
- vDeriv Vector3d
- [in] The tangent vector in the v-direction.
Remarks
Currently not
implemented.
See Also