VertexData Class

This class contains arrays of vertex attributes for meshes and shells. VertexData objects are optional; they can be optionally passed to WorldGeometry and ViewportGeometry when using their mesh and shell methods.
Inheritance Hierarchy
SystemObject
  Teigha.GraphicsInterfaceVertexData

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class VertexData

The VertexData type exposes the following members.

Constructors
  Name Description
Public method VertexData Initializes a new instance of the VertexData class
Top
Properties
  Name Description
Public property OrientationFlag Property that represents an orientation type indicating the positive direction of the normal at the vertices.
Top
Methods
  Name Description
Public method get_MappingCoords Returns mapping coordinates of the vertex data.
Public method GetNormalVectors Returns an array of normal vectors of the vertex data.
Public method GetTrueColors Returns an array of colors of the vertex data.
Public method set_MappingCoords Sets mapping coordinates of the vertex data.
Public method SetNormalVectors Sets an array of vertex normal vectors.
Public method SetTrueColors Sets an array of colors for this vertex data.
Top
See Also

©  Bricsys NV. All rights reserved.