LinearEntity3dIsPerpendicularTo(LinearEntity3d,
Tolerance) Method
|
Checks whether the specified line is
perpendicular to this linear entity according to a tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsPerpendicularTo(
LinearEntity3d line,
Tolerance tolerance
)
Public Function IsPerpendicularTo (
line As LinearEntity3d,
tolerance As Tolerance
) As Boolean
public:
bool IsPerpendicularTo(
LinearEntity3d^ line,
Tolerance tolerance
)
member IsPerpendicularTo :
line : LinearEntity3d *
tolerance : Tolerance -> bool
Parameters
- line LinearEntity3d
- [in] 3D linear entity to test for being perpendicular to this
linear entity.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Boolean
true if the specified line is perpendicular to this linear entity,
false otherwise.
See Also