PointCloudExAttachPointCloud Method
|
Creates a point cloud entity and returns the
object ID of the created entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static ObjectId AttachPointCloud(
string filename,
Point3d location,
double scale,
double rotation,
Database db
)
Public Shared Function AttachPointCloud (
filename As String,
location As Point3d,
scale As Double,
rotation As Double,
db As Database
) As ObjectId
public:
static ObjectId AttachPointCloud(
String^ filename,
Point3d location,
double scale,
double rotation,
Database^ db
)
static member AttachPointCloud :
filename : string *
location : Point3d *
scale : float *
rotation : float *
db : Database -> ObjectId
Parameters
- filename String
- [in] Point cloud full file path.
- location Point3d
- [in] Location of a point cloud entity.
- scale Double
- [in] Scale factor.
- rotation Double
- [in] Rotation angle in degrees.
- db Database
- [in] Database that where to add the point cloud entity. The
entity is appended to the currently active space (model or paper
space).
Return Value
ObjectId
See Also