ViewGetNumPixelsInUnitSquare(Point3d)
Method
|
Returns the display pixel density at the
specified point for this Viewport object.
Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual Point2d GetNumPixelsInUnitSquare(
Point3d givenWorldpt
)
Public Overridable Function GetNumPixelsInUnitSquare (
givenWorldpt As Point3d
) As Point2d
public:
virtual Point2d GetNumPixelsInUnitSquare(
Point3d givenWorldpt
)
abstract GetNumPixelsInUnitSquare :
givenWorldpt : Point3d -> Point2d
override GetNumPixelsInUnitSquare :
givenWorldpt : Point3d -> Point2d
Parameters
- givenWorldpt Point3d
- [in] WCS center of the unit square.
Return Value
Point2d
Remarks
Pixel density is
measured in pixels per WCS unit. This method can be used to
determine whether the geometry generated for an object is smaller
than the size of a pixel.
See Also