CircularArc3dClosestPointToPlane(PlanarEntity,
Tolerance) Method
|
Retrieves the closest point on this circular
arc and corresponding point on a specified plane.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] ClosestPointToPlane(
PlanarEntity plane,
Tolerance tolerance
)
Public Function ClosestPointToPlane (
plane As PlanarEntity,
tolerance As Tolerance
) As Point3d()
public:
array<Point3d>^ ClosestPointToPlane(
PlanarEntity^ plane,
Tolerance tolerance
)
member ClosestPointToPlane :
plane : PlanarEntity *
tolerance : Tolerance -> Point3d[]
Parameters
- plane PlanarEntity
- [in] Plane for which the closest points are calculated.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Point3d
Array of the closest points.
Remarks
Indices of the
array of retrieved points: 0: Closest point on this circular arc.
1: Closest point on the passed plane.
See Also