GeometryCircularArc(Point3d, Double,
Vector3d, Vector3d, Double, ArcType)
Method
|
Introduces a circular arc to the vectorization
context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool CircularArc(
Point3d center,
double radius,
Vector3d normal,
Vector3d startVector,
double sweepAngle,
ArcType arcType
)
Public MustOverride Function CircularArc (
center As Point3d,
radius As Double,
normal As Vector3d,
startVector As Vector3d,
sweepAngle As Double,
arcType As ArcType
) As Boolean
public:
virtual bool CircularArc(
Point3d center,
double radius,
Vector3d normal,
Vector3d startVector,
double sweepAngle,
ArcType arcType
) abstract
abstract CircularArc :
center : Point3d *
radius : float *
normal : Vector3d *
startVector : Vector3d *
sweepAngle : float *
arcType : ArcType -> bool
Parameters
- center Point3d
- [in] Center point.
- radius Double
- [in] Radius.
- normal Vector3d
- [in] Normal vector.
- startVector Vector3d
- [in] Start of the arc.
- sweepAngle Double
- [in] Angle that defines the arc.
- arcType ArcType
- [in] Arc type.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
Remarks
arcType must be
one of the following: Name Value Description ArcSimple 0 Unfilled.
ArcSector 1 Filled area bounded by the arc and its center. ArcChord
2 Filled area bounded by the arc and its end points.
See Also