GeometryCircle(Point3d, Double,
Vector3d) Method
|
Introduces a circle to the vectorization
context.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool Circle(
Point3d center,
double radius,
Vector3d normal
)
Public MustOverride Function Circle (
center As Point3d,
radius As Double,
normal As Vector3d
) As Boolean
public:
virtual bool Circle(
Point3d center,
double radius,
Vector3d normal
) abstract
abstract Circle :
center : Point3d *
radius : float *
normal : Vector3d -> bool
Parameters
- center Point3d
- [in] Center point.
- radius Double
- [in] Radius.
- normal Vector3d
- [in] Normal to the plane on which the circle lies.
Return Value
Boolean
true. This method also throws a corresponding exception if it
fails.
See Also