Spline(Int32, Boolean, Boolean, Boolean,
Point3dCollection, DoubleCollection,
DoubleCollection, Double, Double) Constructor
|
Constructor for the Spline class.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Spline(
int degree,
bool rational,
bool closed,
bool periodic,
Point3dCollection controlPoints,
DoubleCollection knots,
DoubleCollection weights,
double controlPointTolerance,
double knotTolerance
)
Public Sub New (
degree As Integer,
rational As Boolean,
closed As Boolean,
periodic As Boolean,
controlPoints As Point3dCollection,
knots As DoubleCollection,
weights As DoubleCollection,
controlPointTolerance As Double,
knotTolerance As Double
)
public:
Spline(
int degree,
bool rational,
bool closed,
bool periodic,
Point3dCollection^ controlPoints,
DoubleCollection^ knots,
DoubleCollection^ weights,
double controlPointTolerance,
double knotTolerance
)
new :
degree : int *
rational : bool *
closed : bool *
periodic : bool *
controlPoints : Point3dCollection *
knots : DoubleCollection *
weights : DoubleCollection *
controlPointTolerance : float *
knotTolerance : float -> Spline
Parameters
- degree Int32
-
- rational Boolean
- [in] Flag that indicates whether the spline is rational.
- closed Boolean
- [in] Flag that indicates whether the spline is closed.
- periodic Boolean
-
- controlPoints Point3dCollection
- [in] Control points.
- knots DoubleCollection
- [in] Knot values of the spline.
- weights DoubleCollection
- [in] Weight values at each control point of the spline.
- controlPointTolerance Double
- [in] Control points tolerance of the spline.
- knotTolerance Double
- [in] Knot value tolerance of the spline.
See Also