Curve3dGetProjectedEntity(Plane,
Vector3d) Method
|
Retrieves the entity representing the curve's
projection onto the projection plane.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Entity3d GetProjectedEntity(
Plane projectionPlane,
Vector3d projectDirection
)
Public Function GetProjectedEntity (
projectionPlane As Plane,
projectDirection As Vector3d
) As Entity3d
public:
Entity3d^ GetProjectedEntity(
Plane^ projectionPlane,
Vector3d projectDirection
)
member GetProjectedEntity :
projectionPlane : Plane *
projectDirection : Vector3d -> Entity3d
Parameters
- projectionPlane Plane
- [in] Plane on which the curve is to be projected.
- projectDirection Vector3d
- [in] Direction in which the curve is to be projected.
Return Value
Entity3d
The entity that is the result of the projection.
See Also