Plane Class

This class represents infinite planes in 3D space. For more information, see Working with Planes.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurface
          Teigha.GeometryPlanarEntity
            Teigha.GeometryPlane

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class Plane : PlanarEntity

The Plane type exposes the following members.

Constructors
  Name Description
Public method Plane Default constructor for the Plane class. Creates a default corresponding C++ XY plane object.
Public method Plane(Plane) Copy constructor for the Plane class. Copies the passed plane.
Public method Plane(Point3d, Vector3d) Constructor for the Plane class. Creates a plane from a normal to the plane and plane origin.
Public method Plane(Point3d, Point3d, Point3d) Constructor for the Plane class. Creates a plane with points that define the u- and v-axes and an origin point of the plane.
Public method Plane(Point3d, Vector3d, Vector3d) Constructor for the Plane class. Creates a plane with points that define u- and v-axes and an origin point of the plane.
Public method Plane(Double, Double, Double, Double) Constructor for the Plane class. Creates a plane with specified coefficients for the plane equation. The plane equation for this plane is as follows:
C#
a * x + b * y + c * z + d = 0
Top
Properties
  Name Description
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetSignedDistanceTo Returns the signed distance to (elevation of) the specified point. The sign of the result is the same as the sign of the dot product of the vector: pointValue - originOfPlane and the normal to the plane.
Public method IntersectWith(BoundedPlane) Returns the intersection line segment if the specified bounded plane intersects with this plane.
Public method IntersectWith(Plane) Returns the intersection line segment if the specified plane intersects with this plane.
Public method IntersectWith(BoundedPlane, Tolerance) Returns the intersection line segment if the specified bounded plane intersects with this plane according to a geometric tolerance.
Public method IntersectWith(Plane, Tolerance) Returns the intersection line segment if the specified plane intersects with this plane according to a geometric tolerance.
Public method Set(Point3d, Vector3d) Sets the parameters for this plane according to the arguments.
Public method Set(Point3d, Point3d, Point3d) Sets the parameters for this plane according to the arguments.
Public method Set(Point3d, Vector3d, Vector3d) Sets the parameters for this plane according to the arguments.
Public method Set(Double, Double, Double, Double) Sets the parameters for this plane according to the arguments.
Top
See Also

©  Bricsys NV. All rights reserved.