GeometryEllipticalArc Method
|
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool EllipticalArc(
Point3d center,
Vector3d normal,
double majorAxisLength,
double minorAxisLength,
double startDegreeInRads,
double endDegreeInRads,
double tiltDegreeInRads,
ArcType arType
)
Public MustOverride Function EllipticalArc (
center As Point3d,
normal As Vector3d,
majorAxisLength As Double,
minorAxisLength As Double,
startDegreeInRads As Double,
endDegreeInRads As Double,
tiltDegreeInRads As Double,
arType As ArcType
) As Boolean
public:
virtual bool EllipticalArc(
Point3d center,
Vector3d normal,
double majorAxisLength,
double minorAxisLength,
double startDegreeInRads,
double endDegreeInRads,
double tiltDegreeInRads,
ArcType arType
) abstract
abstract EllipticalArc :
center : Point3d *
normal : Vector3d *
majorAxisLength : float *
minorAxisLength : float *
startDegreeInRads : float *
endDegreeInRads : float *
tiltDegreeInRads : float *
arType : ArcType -> bool
Parameters
- center Point3d
-
- normal Vector3d
-
- majorAxisLength Double
-
- minorAxisLength Double
-
- startDegreeInRads Double
-
- endDegreeInRads Double
-
- tiltDegreeInRads Double
-
- arType ArcType
-
Return Value
Boolean
See Also