HostApplicationServicesFindFileEx Method

Returns the fully qualified path to the specified file.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public string FindFileEx(
        string fileName,
        Database database,
        FindFileHint hint
)

Parameters

fileName  String
[in] Name of the file to find.
database  Database
[in] Pointer to the database context.
hint  FindFileHint
[in] Hint that indicates the type of file that is required.

Return Value

String
Remarks
Returns an empty string if the file is not found. The method should be called when the database needs access to a file, such as a font file, a template file, etc. The typical search order is as follows: 1. The filename itself. 2. The current directory. 3. The drawing directory (for SHX font, image, and xref files). 4. The directories listed in the environment variable. 5. The Microsoft(R) Windows(R) fonts directory (only for TTF fonts on Windows). hint must be one of the following:
Name Value Description Extension
kDefault 0 Any file any
kFontFile 1 Can be either SHX or TTF file SHX or TTF
kCompiledShapeFile 2 SHX file. SHX
kTrueTypeFontFile 3 TTF file TTF
kEmbeddedImageFile 4 Image file ISM
kXRefDrawing 5 Drawing template file DWT
kPatternFile 6 Pattern file (PAT) PAT
kTXApplication 7 ODA Xtension file. TX
kFontMapFile 8 FontMap file FMP
kUnderlayFile 9 Underlay file
kTextureMapFile 10 Texture map file
See Also

©  Bricsys NV. All rights reserved.