HostApplicationServices Class

This .NET class wraps the OdDbHostAppServices class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.DatabaseServicesHostApplicationServices

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class HostApplicationServices : RXObject

The HostApplicationServices type exposes the following members.

Constructors
  Name Description
Protected method HostApplicationServices Initializes a new instance of the HostApplicationServices class
Protected method HostApplicationServices(IntPtr, Boolean) Initializes a new instance of the HostApplicationServices class
Top
Properties
  Name Description
Public property AlternateFontName Property that represents the name of the 'alternate' or default font that is used when no other font can be found.
Public property CompanyName Property that represents the name of the company that owns the application.
Public propertyStatic member Current Represents the currently active host application services object.
Public property FontMapFileName Property that represents the name of the fontmap file. Such files contain a list of font names and substitute fonts that are used in place of the named fonts. Default implementation retrieves an empty string.
Public property GRIPCOLOR Property that represents the color of grips that are not selected. The value can be [1..255].
Public property GRIPHOT Property that represents the color of grips that are not selected. The value can be [1..255].
Public property GRIPHOVER Property that represents the ACI color index of unselected grips when the cursor hovers over them. The value can be [0..257].
Public property GRIPOBJLIMIT Property that represents the number of selected objects beyond which grips are suppressed for a selection set. This property can be in the range [0..32767].
Public property GRIPSIZE Property that represents the size of the grip box. The value can be [1..255] pixels.
Public property LocalRootFolder Property that represents a path to the root folder. Default implementation retrieves an empty string.
Public property MachineRegistryProductRootKey  
Public property ModelerFlavor Property that represents possible levels of geometric modeler support available from the host applications.
Public property Product Property that represents the name of the product.
Public property Program Property that represents the name of the program.
Public property RegistryProductRootKey  
Public property ReleaseMajorVersion Property that represents the release major version of the client application.
Public property ReleaseMinorVersion Property that represents the release minor version of the client application.
Public property RoamableRootFolder Property that represents a path to the local roamable files directory. Default implementation retrieves an empty string.
Public property TEXTFILL Property that indicates whether TrueType fonts are filled.
Public property UserRegistryProductRootKey  
Public property VersionString Property that represents a string with release major and minor versions.
Public propertyStatic member WorkingDatabase Property that represents the currently active database.
Top
Methods
  Name Description
Public method BitmapDevice Returns the gsBitmapDevice associated with this HostApplicationServices object. Currently not implemented.
Public method FindFile Returns the fully qualified path to the specified file.
Public method FindFileEx Returns the fully qualified path to the specified file.
Public method GetPassword(String, PasswordOptions) Obsolete.
Host applications call this method internally to display a password request dialog box. Currently not implemented.
Public method GetPassword(String, PasswordOptions, String) Host applications call this method internally to display a password request dialog box. Currently not implemented.
Public method GetRemoteFile  
Public method GetSystemFontFolders Provides access to the list of system font folders. Paths to the folders are stored in ACAD system variable.
Public method GetUrl Maps a local file to the corresponding URL from which the file was downloaded.
Public method IsUrl Determines whether the passed string is a valid URL. Currently not implemented.
Public method LoadApplication Loads an application. Currently not implemented.
Public method NewProgressMeter Retrieves a progress bar that represents visual progress of completion for some processes. Currently not implemented.
Public method PutRemoteFile  
Public method recoverFile Performs a recover operation on the specified file defined in a file buffer.
Public method RegisterTrueTypeFonts Takes fonts from directories set by ACAD environment variable and registers them.
Public method RegisterTrueTypeFonts(ListString)  
Public method TtfFileNameByDescriptor Locates the TTF or TTC file containing the specified font description.
Public method UserBreak Usually called by the database code to determine whether the user has pressed a CTRL+C break. Currently not implemented.
Top
See Also

©  Bricsys NV. All rights reserved.